Getting Ready for Android 10

Google has released a beta for their next major mobile OS release, Android 10. This page will serve as a hub to keep you up to date on Android 10 and prepare your devices for the update (expected in Q3 this year). Please subscribe to this page to get notified of all changes made to stay up-to-date as Android 10 gets closer to general availability.

 

General Information

As of March 13th, 2019, Android 10 is available for users to test on Pixel devices. According to the beta program overview page, 6 beta releases are expected, leading up to GA in Q3 2019.

Beta_Timeline.png

If you’re interested in participating in the Android 10 beta program, you can review your options here. We encourage updating test devices to the Android 10 beta and ensure that internally developed applications function as expected. We also recommended reviewing the behavior changes that affect all apps and apps that target Android 10.

 

What’s new in Android 10

A complete list of new Android Enterprise features in Android 10 is available here.

 

Device Admin Deprecation

As discussed previously in our public blog, Google has deprecated some capabilities for device administrators in Android 10. Features below will continue to be functional until Intelligent Hub begins targeting API level 29 later in 2019:

  • Ability to enforce complexity for device passcodes
  • Ability to enforce passcode changes after a set time limit
  • Ability to disable camera
  • Ability to disable keyguard features
  • Ability to report Serial Number and ICCID

We highly encourage migrating devices enrolled using device administrator to Android Enterprise. If a cap and grow strategy is being employed (only new enrollments are on Android Enterprise, old enrollments are on device administrator), ensure that legacy devices are not updated to Android 10.

 

Pop-up warnings for apps targeting API level 22 and older

In Android 10, When an app is initially run after being installed, the platform will warn users if the app targets a platform version lower than Android 6.0 (API level 23). If the app requires the user to grant permissions, the user will also be given an opportunity to adjust the app's permissions before the app is permitted to run for the first time.
More information can be found here.

The Workspace ONE Launcher and AirWatch Container will be impacted by this change when a device has been upgraded to Android 10. The warning will be displayed when the app is being configured for the first time. The Workspace ONE Team is diligently working to update the target API level in Workspace ONE Launcher.

 

Location permissions requirement in Android 10 Work Profile

Google has made a change to how Intelligent Hub manages Wi-Fi networks on Work Profile devices and now requires that the location permissions be enabled in order to remove the profile. Without this permission the only method to remove a wi-fi network configuration is to unenroll the device.
Note: Unenrolling the device will remove the entirety of the Work Profile.

 

Changes to application switching on Workspace ONE Intelligent Hub on Android Legacy Enrollment

In Android 10 applications will no longer have the ability to bring themselves to the foreground from the background. This change impacts many workflows which require that an app be moved to the background or brought to the foreground such as Legacy Android enrollment. Newly enrolling an Android 10 device into Android Legacy may require that the user manually re-open the Intelligent Hub during enrollment depending on the selected enrollment flow in the environment.
Note: Enrolling Android 10 devices into Android Legacy is strongly discouraged.

Impact on Android Legacy Devices

  • AAGNT-186307: [Android Legacy] User is not taken back to enrollment screen after email client app is installed from play store
  • AAGNT-186308: [Android Legacy] Internal app install prompt gets hidden by Processing Application Install screen
  • AAGNT-186310: [Android Legacy] Intelligent Hub doesn't prompt to install/uninstall app or to update password when it's running in background
  • AAGNT-186710: [Android Legacy][Device Owner]Serial number in the device details screen is shown empty. 
  • FCA-191507: [Android Legacy] Unable to assign the Telecom Plans for Android 10 devices

 

VMware application support for Android 10

VMware validates applications with the latest OS releases to ensure your devices will be successful upon upgrade. To ensure a successful upgrade, users are encouraged to update to the specified version of each Android app listed below to fully support Android 10.

Application Android 10 Supported Version
Boxer 5.9
Content 3.19
Intelligent Hub 19.07 
Launcher 4.4.1
Notebook 1.1
SDK 19.7 
Send 1.2.1 
Tunnel 5.2 
Web 7.7
Workspace ONE 3.3.5 

Note: AirWatch Relay and AirWatch Container will not be supported in Android 10. 

 

Known Issues

Our team is actively testing Android 10 to prepare for the Q3 release. Current known issues are listed below:

  • AAGNT-186221: Required Device Password for installing the certs notification can not launch change device password activity
  • AAGNT-186709: [Device Owner mode] Permission screen is shown twice in Android 10 device
  • ASDK-170823: Downloading a file from a site enabled for Integrated Auth fails intermittently when going through proxy in Workspace ONE Web for Android
  • ALAU-170442: Serial number shown within Launcher app's device details area is blank
  • ALAU-170500: Permissions screen shown twice during setup
  • ALAU-170501: If location permission is declined, Wi-Fi scan results will show as empty
  • ALAU-170502: If notification and status bars are hidden we cannot show a Phone call notification
  • ALAU-170511: Security pop-up is shown due to old target SDK level

 

 

Support Contact Information

To receive support, either submit a ticket via the My Workspace ONE  portal or call your local support line.

 

Best Regards,
The VMware Workspace ONE Team

 

Other Languages: 日本語

Have more questions? Submit a request

3 Comments

  • 0
    Avatar
    The Workspace ONE Team

    Update: Supported Applications in Android Q

    Application Android Q Supported Version
    Boxer 5.9
    Content 3.19
    Intelligent Hub 19.07 
    Launcher 4.4.1
    Notebook 1.1
    SDK TBD 
    Tunnel TBD 
    Web 7.7
    Workspace ONE TBD 

    Support Contact Information

    To receive support, either submit a ticket via the My Workspace ONE portal or call your local support line.

     

    Best Regards,

    The VMware Workspace ONE Team

     

  • 0
    Avatar
    The Workspace ONE Team

    Update Regarding Getting Ready for Android 10 and Workspace ONE UEM

    New Android Legacy Known Issue Added

    Known Issues:

    • AAGNT-186307: [Android Legacy] User is not taken back to enrollment screen after email client app is installed from play store
    • AAGNT-186308: [Android Legacy] Internal app install prompt gets hidden by Processing Application Install screen
    • AAGNT-186310: [Android Legacy] Intelligent Hub doesn't prompt to install/uninstall app or to update password when it's running in background
    • AAGNT-186710: [Android Legacy][Device Owner]Serial number in the device details screen is shown empty. 
    • FCA-191507: [Android Legacy] Unable to assign the Telecom Plans for Android 10 devices

    Support Contact Information

    To receive support, either submit a ticket via the My Workspace ONE portal or call your local support line.

     

    Best Regards,

    The VMware Workspace ONE Team

     

  • 0
    Avatar
    The Workspace ONE Team

    Update Regarding Getting Ready for Android 10 and Workspace ONE UEM

    New Supported App Version

    Application Android 10 Supported Version
    Boxer 5.9
    Content 3.19
    Intelligent Hub 19.07 
    Launcher 4.4.1
    Notebook 1.1
    SDK ** 19.7 **
    Tunnel TBD 
    Web 7.7
    Workspace ONE 3.3.5 

    Support Contact Information

    To receive support, either submit a ticket via the My Workspace ONE portal or call your local support line.

     

    Best Regards,

    The VMware Workspace ONE Team

     

Article is closed for comments.