Upcoming Changes to Cloud Messaging Services in Environments Utilizing Android Devices

Overview

Android devices have two existing methods for providing immediate feedback for functionality across the VMware Workspace ONE UEM suite of products, Google Cloud Messaging (GCM) and AirWatch Cloud Messaging (AWCM). Google has announced that they are deprecating GCM effective April 11th, 2019 in favor of a new cloud-messaging platform they released called Firebase Cloud Messaging (FCM). VMware is working diligently to update the VMware Workspace ONE Intelligent Hub to using the new Google standard of FCM.
Find out more on Google’s developer page

All customers are strongly encouraged to upgrade their VMware Workspace ONE UEM Console and Workspace ONE Intelligent Hub application to the versions that contain support for Firebase Cloud Messaging. The Workspace ONE Team is currently working to provide FCM compatibility in the Workspace ONE Intelligent Hub and Workspace ONE UEM releases slated for the first quarter of 2019. The team is also working to provide compatibility patches for supported versions of the Workspace ONE UEM Console. The table below displays the versions which will be supported.
Note: Customers who would like to be informed when new patches are available should subscribe to this article.
 

Workspace ONE UEM Version

Patch Link

1811

18.11.0.5

1810

18.10.0.10

9.7

9.7.0.22

9.6

9.6.0.15

9.5

9.5.0.24

9.4

TBD

9.3

TBD

 

Customer Impact

Once GCM has been deprecated, customers enrolling new devices into GCM enabled environments, will begin experiencing extended delays in communication between the Workspace ONE Console and Android devices. Devices enrolled prior to the deprecation on GCM enabled environments will continue to work normally until their GCM token expires at re-enrollment. It is strongly suggested to upgrade your environment to an FCM compatible version of Workspace ONE UEM and Intelligent Hub.
Note: Environments using AWCM for communication with Android devices will continue to operate as expected with no changes required.

Workspace ONE Administrators may prepare for the deprecation of GCM by upgrading to FCM compatible versions of the Workspace ONE UEM Console and Workspace ONE Intelligent Hub prior to April 11th

 

Additional Information

Depending on whether the environment is hosted or on premises, some changes including changes to network settings may be required in order to use FCM as a replacement for GCM. Please refer to the information below for migration steps.

 

Shared SaaS Environments

  1. Ensure that devices can reach fcm.googleapis.com and fcm-xmpp.googleapis.com over ports TCP/443,5228-5230
  2. Ensure that Android devices are using an FCM compatible version of the Workspace ONE Intelligent Hub, release date TBD

 

Dedicated SaaS Environments 

  1. Ensure that devices can reach fcm.googleapis.com and fcm-xmpp.googleapis.com over ports TCP/443,5228-5230
  2. Request that the correct console patch is applied
  3. Ensure that Android devices are running an FCM compatible version of the Workspace ONE Intelligent Hub, release date TBD

 

On Premises Environments

  1. Ensure your EMM Console and devices can reach fcm.googleapis.com and fcm-xmpp.googleapis.com over TCP/443,5228-5230
  2. Apply the correct patch for your environment based on your Workspace ONE UEM Console version
  3. Ensure that Android devices are running an FCM compatible version of the Workspace ONE Intelligent Hub, release date TBD

 

Support Contact Information

To receive support, either submit a ticket via the My Workspace ONE  portal or call your local support line.

 

Best Regards,

The VMware Workspace ONE Team

 

Other Languages: 日本語

Have more questions? Submit a request

2 Comments

Article is closed for comments.