Android API Level 26 Support with SDK 17.9 for Android

Android SDK 17.9 supports compilation with Android API target version 26. However, there is currently a known technical limitation with SDK applications using API version 26 where some Single Sign-On (SSO) functionality will not be compatible with older versions of AirWatch & SDK applications running versions of the SDK below 17.9. 


Implications for Customers

If your application utilizes API target 26, only Client SDK and SDKContextManager calls will be compatible with applications using an SDK version older than 17.9.

If you are utilizing the splash activity flow from AWFramework in your application if other SDK applications (both custom built and applications from AirWatch) are present in your deployment, it is recommended to wait until the new versions of the applications with SDK 17.9 are released before upgrading your application to API level 26.

This issue will be resolved over time as new versions of AirWatch applications with SDK 17.9+ are released.


Support Contact Information

To open a Support Request, please call your local AirWatch support line or submit a Support Request via myAirWatch.


Best Regards,

The AirWatch Team

Have more questions? Submit a request


Article is closed for comments.