PowerShell: Use Manual Connections to Troubleshoot Test Connection Issues

SYMPTOMS

PowerShell Test Connection unsuccessful. Whitelist/Blacklist commands are not effective

 

CAUSE

AirWatch Components (Console, Device Service or ACC) fails to connect with Exchange PowerShell.

 

RESOLUTION

Creating a manual PowerShell Session with the following script simulates what AirWatch software is doing when testing connection or sending a command. The PowerShell Console tends to provide more details on the error to help identify the issue. The error from the manual connection can also contain links to related Microsoft KB articles with resolutions.

Following is an illustration of a successful manual PowerShell Session

> $cred = Get-credential

> $session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri "https://exch2013.airwatchdev.com/powershell" -Credential $cred -Authentication Basic –AllowRedirection

> Import-PSSessionn $session

 PowerShellManual.png

 

Have more questions? Submit a request

0 Comments

Article is closed for comments.