SEG: Encryption Key Data does Not Exist in Cache for EAS Identifier

Error/Symptom

This error is observed in the verbosed integration service logs of the SEG Server. The exact error is as listed below:

Encryption key data does not exist in cache for EAS identifier *test_eas_device_id*

Error AW.Eas.Helper.WcfExtensions.Execute<IActiveSyncIntegrationService> TimeoutException encountered while while executing <_LoadEncryptionKeyData>b__39

 

Cause

The reason we see this error is because there are timeouts happening when the SEG server is attempting to get the encryption key, but cannot. Hence attachments are not encrypted at times and sometimes encrypted attachments cannot be decrypted.

 

Resolution

  1. Increase the timeout value within the Integration Service configuration file, in the line Activesyncintegration endpoint add 'timeouts=Large'
  2. Edit the WebService  config file on the API server  and add 'timeouts=Large' to the activesyncintegration endpoint
  3. If this does not fix the issue, there is a sproc which runs in the background to retrieve the keys. Involve a DBA and check if the sproc is functioning as expected.

 

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