Upgrade : Database Upgrade: The installation of Microsoft .NET 4.5.2 (Web Download) has failed. Setup will now exit.

Error:

When running Database Upgrade on a server that has .NET 4.6 or .NET 4.6.1 installed the installer begins downloading .NET 4.5.2 and then fails to install it:

Install_1.jpg

Install_2.jpg

Install_3.jpg

Cause:

The Database Installer does not correctly recognize .NET 4.6 or 4.6.1.

Running the following Powershell script confirms the version of .NET installed:

----------------------------------------------------------------------------------------------------------------------------------

Get-ChildItem 'HKLM:\SOFTWARE\Microsoft\NET Framework Setup\NDP' -recurse |

Get-ItemProperty -name Version,Release -EA 0 |

Where { $_.PSChildName -match '^(?!S)\p{L}'} |

Select PSChildName, Version, Release, @{

  name="Product"

  expression={

      switch($_.Release) {

        378389 { [Version]"4.5" }

        378675 { [Version]"4.5.1" }

        378758 { [Version]"4.5.1" }

        379893 { [Version]"4.5.2" }

        393295 { [Version]"4.6" }

        393297 { [Version]"4.6" }

        394254 { [Version]"4.6.1" }

        394271 { [Version]"4.6.1" }

      }

    }

}

-------------------------------------------------------------------------------------------------------------------------

 

In this example the script shows .NET 4.6.1 was installed:

Install_4.jpg

 

Resolution:

As a workaround, please remove the newer version of .NET using the KB version of the update detailed in the following links:

About .NET Framework 4.6

About .NET Framework 4.6.1

 

We uninstalled 'Update for Microsoft Windows (KB3102467)' from Control Panel...Programs & Features...[Installed Updates]

Install_5.jpg

Ran the Powershell script once more to confirm .NET 4.5.2 is now the installed version:

Install_6.jpg

The Database upgrade will now run successfully.

 

Note:  At the very end of the upgrade during the first attempts to login to the admin console you may receive the following error:

Server Error in '/AirWatch' Application.  Runtime Error

Console Log showing:  Method not found: 'Void System.Security.Claims.ClaimsIdentity..(System.Security.Claims.ClaimsIdentity)'

In which case now that the upgrade is complete you can reinstall the KB Article that you previously removed.

You should then be able to login to the web console without issue.

Have more questions? Submit a request

0 Comments

Article is closed for comments.