Restriction on supported settings in Android 5.0 Lollipop for AirWatch Launcher 2.0

Symptoms

Certain restrictions are unavailable when using the AirWatch Launcher on devices running the Android 5.0 Lollipop OS. Due to a discontinuation of APIs to detect an activity within a package (app) in Android 5.0 Lollipop, the Launcher cannot call the API to detect a particular activity for a specific setting within the Settings app. As a result, the AirWatch Launcher cannot whitelist certain settings for which AirWatch relies on native Settings UI in the device Settings app.

The follow settings are currently not supported on Android 5.0 Lollipop:

  • Language Settings
  • Bluetooth Setting
  • Cellular data Setting
  • Tethering Setting
  • Security Setting
  • Screen Lock (new with v2.0)
  • Allowing notifications within the Launcher application
  • Restricting the "Recent Apps" UI (note: even though the UI is available, non-whitelisted apps cannot be accessed)
  • "Allow Multi Window mode" has been removed

Resolution

As of 8.0 FP8, tags have been added to the AirWatch Admin Console to show which Android versions support which specific settings.

Have more questions? Submit a request

0 Comments

Article is closed for comments.